Repeating errors, SickBeard seems OK, though?

Get help with Sick Beard and report/discuss bugs

Repeating errors, SickBeard seems OK, though?

Postby smfb » Sun Apr 12, 2015 10:20 pm

I am getting a lot of errors related to searching in the last couple of months. I thought nothing of it and that an update would fix it soon, but I actually haven't been able to update since I started receiving these errors. I don't know if it's related, but anyways... on to the errors.

Code: Select all
2015-04-12 14:32:05 SEARCHQUEUE-RSS-SEARCH :: Error while searching NZB.su, skipping: coercing to Unicode: need string or buffer, instance found
2015-04-12 13:52:05 SEARCHQUEUE-RSS-SEARCH :: Error while searching NZB.su, skipping: coercing to Unicode: need string or buffer, instance found
2015-04-12 13:12:03 SEARCHQUEUE-RSS-SEARCH :: Error while searching NZB.su, skipping: coercing to Unicode: need string or buffer, instance found
2015-04-12 12:32:04 SEARCHQUEUE-RSS-SEARCH :: Error while searching NZB.su, skipping: coercing to Unicode: need string or buffer, instance found


I am getting a ton of these errors on a daily basis. There are more usually, but my backlog search hasn't started today and I have already cleared the list. Anyone know what is causing this? I checked to make sure all my search settings were correct and I am getting NZBs passed to SABNZBd+ just fine and the program seems to be working OK regardless. In other words, I haven't noticed any problems with SickBeard's functionality.
smfb
 
Posts: 3
Joined: Sun Apr 12, 2015 7:08 pm

Re: Repeating errors, SickBeard seems OK, though?

Postby smfb » Tue Apr 14, 2015 11:05 pm

Backlog ran recently. There are over 100 of these errors.

Code: Select all
2015-04-14 03:52:46 SEARCHQUEUE-RSS-SEARCH :: Error trying to load NZB.su RSS feed
2015-04-14 03:40:32 SHOWQUEUE-REFRESH :: There was an error trying to retrieve the image, aborting
2015-04-14 03:23:53 SEARCHQUEUE-BACKLOG-211751 :: Error trying to load NZB.su XML data
2015-04-14 03:23:53 SEARCHQUEUE-BACKLOG-211751 :: Error trying to load NZB.su XML data
smfb
 
Posts: 3
Joined: Sun Apr 12, 2015 7:08 pm

Re: Repeating errors, SickBeard seems OK, though?

Postby xeddog » Fri Apr 17, 2015 11:31 am

I am not sure if I should open a new thread or add to this one, but I am getting these errors too. The thing is, though, that I also get an additional error message like so:
Code: Select all
2015-04-17 09:20:02 SEARCHQUEUE-RSS-SEARCH :: Error while searching NZB.Su, skipping: coercing to Unicode: need string or buffer, instance found
2015-04-17 09:20:02 SEARCHQUEUE-RSS-SEARCH :: No NZB/Torrent providers found or enabled in the sickbeard config. Please check your settings.

The log for the messages above shows:
Code: Select all
2015-04-17 09:20:00 DEBUG    SHOWQUEUE-FORCE-UPDATE :: Attempting to supplement show info with info from TVRage
2015-04-17 09:20:00 DEBUG    SHOWQUEUE-FORCE-UPDATE :: Loading TVRage info from URL: http://services.tvrage.com/tools/quickinfo.php?show=Haven
2015-04-17 09:20:00 INFO     SHOWQUEUE-FORCE-UPDATE :: Checking the last aired episode to see if the dates match between TVDB and TVRage
2015-04-17 09:20:00 WARNING  SHOWQUEUE-FORCE-UPDATE :: Unable to add TVRage info: TVRage doesn't have all the required info for this show
2015-04-17 09:20:02 INFO     SEARCHQUEUE-RSS-SEARCH :: Changing all old missing episodes (UNAIRED) to status WANTED
2015-04-17 09:20:02 DEBUG    SEARCHQUEUE-RSS-SEARCH :: sickbeard.db: SELECT * FROM tv_episodes WHERE status = ? AND season > 0 AND airdate < ? with args [1, 735705]
2015-04-17 09:20:02 INFO     SHOWQUEUE-REFRESH :: Performing refresh on Haven
2015-04-17 09:20:02 INFO     SEARCHQUEUE-RSS-SEARCH :: Beginning search for new episodes on RSS
2015-04-17 09:20:02 INFO     SEARCHQUEUE-RSS-SEARCH :: Searching all providers for any needed episodes
2015-04-17 09:20:02 DEBUG    SEARCHQUEUE-RSS-SEARCH :: cache.db: SELECT time FROM lastUpdate WHERE provider = ? with args ['nzb_su']
2015-04-17 09:20:02 DEBUG    SEARCHQUEUE-RSS-SEARCH :: NZB.Su cache update URL: https://api.nzb.su/api?apikey=68f0678366455dcb7cefa32fc989fc0f&t=tvsearch&cat=5030%2C5040
2015-04-17 09:20:02 INFO     SHOWQUEUE-REFRESH :: 158661: Loading all episodes from the show directory /media/Popcorn/Video/TV Shows/Haven
2015-04-17 09:20:02 INFO     SHOWQUEUE-REFRESH :: 158661: Loading all episodes with a location from the database
2015-04-17 09:20:02 DEBUG    SHOWQUEUE-REFRESH :: sickbeard.db: SELECT * FROM tv_episodes WHERE showid = ? AND location != '' with args [158661]
2015-04-17 09:20:02 DEBUG    SHOWQUEUE-REFRESH :: Running metadata routines for MediaBrowser
2015-04-17 09:20:02 DEBUG    SHOWQUEUE-REFRESH :: Running metadata routines for XBMC 12+
2015-04-17 09:20:02 DEBUG    SHOWQUEUE-REFRESH :: Running metadata routines for Mede8er
2015-04-17 09:20:02 DEBUG    SHOWQUEUE-REFRESH :: Running metadata routines for TIVO
2015-04-17 09:20:02 DEBUG    SHOWQUEUE-REFRESH :: Running metadata routines for WDTV
2015-04-17 09:20:02 DEBUG    SHOWQUEUE-REFRESH :: Running metadata routines for XBMC
2015-04-17 09:20:02 DEBUG    SHOWQUEUE-REFRESH :: Running metadata routines for Sony PS3
2015-04-17 09:20:02 INFO     SHOWQUEUE-REFRESH :: 158661: Writing NFOs for show
2015-04-17 09:20:02 INFO     SHOWQUEUE-REFRESH :: 158661: Writing NFOs for all episodes
2015-04-17 09:20:02 DEBUG    SHOWQUEUE-REFRESH :: sickbeard.db: SELECT * FROM tv_episodes WHERE showid = ? AND location != '' with args [158661]
2015-04-17 09:20:02 INFO     SHOWQUEUE-REFRESH :: Checking & filling cache for show Haven
2015-04-17 09:20:02 DEBUG    SHOWQUEUE-REFRESH :: Checking if we need any cache images for show 158661
2015-04-17 09:20:02 DEBUG    SHOWQUEUE-REFRESH :: Checking if file /home/twoblues/SickBeard/cache/images/158661.poster.jpg exists
2015-04-17 09:20:02 DEBUG    SHOWQUEUE-REFRESH :: Checking if file /home/twoblues/SickBeard/cache/images/158661.banner.jpg exists
2015-04-17 09:20:02 INFO     SHOWQUEUE-REFRESH :: No new cache images needed, not retrieving new ones
2015-04-17 09:20:02 ERROR    SEARCHQUEUE-RSS-SEARCH :: Error while searching NZB.Su, skipping: coercing to Unicode: need string or buffer, instance found
2015-04-17 09:20:02 DEBUG    SEARCHQUEUE-RSS-SEARCH :: Traceback (most recent call last):
  File "/home/twoblues/SickBeard/sickbeard/search.py", line 161, in searchForNeededEpisodes
    curFoundResults = curProvider.searchRSS()
  File "/home/twoblues/SickBeard/sickbeard/providers/generic.py", line 182, in searchRSS
    self.cache.updateCache()
  File "/home/twoblues/SickBeard/sickbeard/tvcache.py", line 104, in updateCache
    data = self._getRSSData()
  File "/home/twoblues/SickBeard/sickbeard/providers/newznab.py", line 520, in _getRSSData
    data = self.provider.getURL(rss_url)
  File "/home/twoblues/SickBeard/sickbeard/providers/generic.py", line 114, in getURL
    response = helpers.getURL(req)
  File "/home/twoblues/SickBeard/sickbeard/helpers.py", line 179, in getURL
    obj = getURLFileLike(url, validate, cookies, password_mgr, throw_exc)
  File "/home/twoblues/SickBeard/sickbeard/helpers.py", line 227, in getURLFileLike
    logger.log(u"HTTP error " + str(e.code) + " while loading URL " + url, logger.WARNING)
TypeError: coercing to Unicode: need string or buffer, instance found

2015-04-17 09:20:02 ERROR    SEARCHQUEUE-RSS-SEARCH :: No NZB/Torrent providers found or enabled in the sickbeard config. Please check your settings.
2015-04-17 09:20:02 INFO     SEARCHQUEUE-RSS-SEARCH :: No needed episodes found on the RSS fee


I might only get two or three pairs of these messages a day, or I might get 50. As with the OP though, SB still seems to be doing it's job. There was only one instance where I had any problem that I could find on my network, and that was with my media server (a PopcornHour A210) when the Ethernet port seemed to have just quit. All other instances that I have looked into over the past month or so have yielded no problems on my network or machine.

Thanks,

Wayne

Computer:
Intel® Core™ i7-4770K CPU @ 3.50GHz × 8
16GB RAM
64-bit Ubuntu Linux 14.04 LTS


Software:
SABnzbd+, SickBeard, and CouchPotatoServer all running on this computer, and all up-to-date.
xeddog
 
Posts: 30
Joined: Tue Mar 29, 2011 11:43 am

Re: Repeating errors, SickBeard seems OK, though?

Postby lpallard » Sat Apr 25, 2015 5:34 am

Not hijacking this thread, but a few weeks back SB started acting up for me too... Logs are filled with thousands of
Code: Select all
2015-04-25 04:12:03 SEARCHQUEUE-RSS-SEARCH :: Error while searching Newznab, skipping: coercing to Unicode: need string or buffer, instance found
2015-04-25 03:52:02 SEARCHQUEUE-RSS-SEARCH :: Error while searching Newznab, skipping: coercing to Unicode: need string or buffer, instance found
2015-04-25 03:32:04 SEARCHQUEUE-RSS-SEARCH :: Error while searching Newznab, skipping: coercing to Unicode: need string or buffer, instance found
2015-04-25 03:12:02 SEARCHQUEUE-RSS-SEARCH :: Error while searching Newznab, skipping: coercing to Unicode: need string or buffer, instance found
2015-04-25 02:52:01 SEARCHQUEUE-RSS-SEARCH :: Error while searching Newznab, skipping: coercing to Unicode: need string or buffer, instance found
2015-04-25 02:38:13 SEARCHQUEUE-BACKLOG-77398 :: Error while searching Newznab, skipping: coercing to Unicode: need string or buffer, instance found
2015-04-25 02:38:10 SEARCHQUEUE-BACKLOG-77398 :: Error while searching Newznab, skipping: coercing to Unicode: need string or buffer, instance found
2015-04-25 02:38:09 SEARCHQUEUE-BACKLOG-77398 :: Error while searching Newznab, skipping: coercing to Unicode: need string or buffer, instance found
2015-04-25 02:38:04 SEARCHQUEUE-BACKLOG-77398 :: Error while searching Newznab, skipping: coercing to Unicode: need string or buffer, instance found
2015-04-25 02:38:01 SEARCHQUEUE-BACKLOG-77398 :: Error while searching Newznab, skipping: coercing to Unicode: need string or buffer, instance found
2015-04-25 02:38:00 SEARCHQUEUE-BACKLOG-77398 :: Error while searching Newznab, skipping: coercing to Unicode: need string or buffer, instance found
2015-04-25 02:37:55 SEARCHQUEUE-BACKLOG-77398 :: Error while searching Newznab, skipping: coercing to Unicode: need string or buffer, instance found
2015-04-25 02:37:52 SEARCHQUEUE-BACKLOG-77398 :: Error while searching Newznab, skipping: coercing to Unicode: need string or buffer, instance found
2015-04-25 02:37:50 SEARCHQUEUE-BACKLOG-77398 :: Error while searching Newznab, skipping: coercing to Unicode: need string or buffer, instance found
2015-04-25 02:37:48 SEARCHQUEUE-BACKLOG-76354 :: Error while searching Newznab, skipping: coercing to Unicode: need string or buffer, instance found
2015-04-25 02:37:28 SEARCHQUEUE-BACKLOG-75340 :: Error while searching Newznab, skipping: coercing to Unicode: need string or buffer, instance found
2015-04-25 02:37:27 SEARCHQUEUE-BACKLOG-75340 :: Error while searching Newznab, skipping: coercing to Unicode: need string or buffer, instance found
2015-04-25 02:37:22 SEARCHQUEUE-BACKLOG-266091 :: Error while searching Newznab, skipping: coercing to Unicode: need string or buffer, instance found
2015-04-25 02:37:09 SEARCHQUEUE-BACKLOG-79501 :: Error while searching Newznab, skipping: coercing to Unicode: need string or buffer, instance found
2015-04-25 02:37:03 SEARCHQUEUE-BACKLOG-121361 :: Error while searching Newznab, skipping: coercing to Unicode: need string or buffer, instance found
2015-04-25 02:37:00 SEARCHQUEUE-BACKLOG-121361 :: Error while searching Newznab, skipping: coercing to Unicode: need string or buffer, instance found
2015-04-25 02:36:58 SEARCHQUEUE-BACKLOG-79349 :: Error while searching Newznab, skipping: coercing to Unicode: need string or buffer, instance found
2015-04-25 02:36:56 SEARCHQUEUE-BACKLOG-84947 :: Error while searching Newznab, skipping: coercing to Unicode: need string or buffer, instance found
2015-04-25 02:36:51 SEARCHQUEUE-BACKLOG-257655 :: Error while searching Newznab, skipping: coercing to Unicode: need string or buffer, instance found
2015-04-25 02:36:48 SEARCHQUEUE-BACKLOG-257655 :: Error while searching Newznab, skipping: coercing to Unicode: need string or buffer, instance found
2015-04-25 02:36:48 SEARCHQUEUE-BACKLOG-257655 :: Error while searching Newznab, skipping: coercing to Unicode: need string or buffer, instance found
2015-04-25 02:31:59 SEARCHQUEUE-RSS-SEARCH :: Error while searching Newznab, skipping: coercing to Unicode: need string or buffer, instance found
2015-04-25 02:12:02 SEARCHQUEUE-RSS-SEARCH :: Error while searching Newznab, skipping: coercing to Unicode: need string or buffer, instance found
2015-04-25 01:51:59 SEARCHQUEUE-RSS-SEARCH :: Error while searching Newznab, skipping: coercing to Unicode: need string or buffer, instance found
2015-04-25 01:32:02 SEARCHQUEUE-RSS-SEARCH :: Error while searching Newznab, skipping: coercing to Unicode: need string or buffer, instance found
2015-04-25 01:30:52 FINDPROPERS :: Exception generated in thread FINDPROPERS: coercing to Unicode: need string or buffer, instance found
2015-04-25 01:12:00 SEARCHQUEUE-RSS-SEARCH :: Error while searching Newznab, skipping: coercing to Unicode: need string or buffer, instance found
2015-04-25 00:51:58 SEARCHQUEUE-RSS-SEARCH :: Error while searching Newznab, skipping: coercing to Unicode: need string or buffer, instance found
2015-04-25 00:32:00 SEARCHQUEUE-RSS-SEARCH :: Error while searching Newznab, skipping: coercing to Unicode: need string or buffer, instance found


Cant remember if this started after a SickBeard update (via the web interface always!) or not.. I do remember that I ran a "yum update" on the machine and updated several packages. Perhaps one of them broke Sickbeard? Couchpotato and SAB seems to be fine..

Anybody who can shed light on this is much appreciated!
lpallard
 
Posts: 8
Joined: Tue Apr 12, 2011 5:25 pm

Re: Repeating errors, SickBeard seems OK, though?

Postby fauxname » Sun May 03, 2015 4:49 pm

I just got back home after a month away, so it's difficult to pin down exactly when this started happening, but I'm getting the same errors as everyone else in this thread.

Any ideas?
fauxname
 
Posts: 1
Joined: Sat May 02, 2015 8:31 pm

Re: Repeating errors, SickBeard seems OK, though?

Postby lpallard » Mon May 04, 2015 4:46 pm

I have opened a ticket ion the project's Google code page, issue 2589

https://code.google.com/p/sickbeard/iss ... il?id=2589

Several people are experiencing this out of the blue, I cant believe no dev has jumped on that yet!

I encourage people with the same issue to post on the Google code ticket so to raise its priority and attract dev's attention.
lpallard
 
Posts: 8
Joined: Tue Apr 12, 2011 5:25 pm

Re: Repeating errors, SickBeard seems OK, though?

Postby Stormbringer » Fri May 08, 2015 7:00 pm

All,

I have a fix that worked for me - as I am not a python expert, I don't claim this is the correct way to do it, but it might get you through until it's fixed in the repository:

Edit Sick-Beard/sickbeard/helpers.py

In line 227, remove the "str()" from around the e.code so it reads like:
Code: Select all
logger.log(u"HTTP error " + e.code + " while loading URL " + url, logger.WARNING)


Then, do the same down in line 234 so it reads like:
Code: Select all
logger.log(u"URL error " + e.reason + " while loading URL " + url, logger.WARNING)


That allowed it to work on my system... that's all I know.
Stormbringer
 
Posts: 2
Joined: Fri May 08, 2015 6:40 pm

Re: Repeating errors, SickBeard seems OK, though?

Postby k3ppp » Sun Jun 21, 2015 8:02 pm

Works for me too
k3ppp
 
Posts: 1
Joined: Sun Jun 21, 2015 8:00 pm


Return to Support / Bug Reports

Who is online

Users browsing this forum: No registered users and 1 guest