TorrentProviders + 1080 + subtitles

Discussion and support for junalmeida's Torrent Edition fork.

TorrentProviders + 1080 + subtitles

Postby junalmeida » Mon Feb 18, 2013 12:31 am

Most of you know my default branch that brings many torrent providers to Sick-Beard.

I'm starting a new branch that reunite all these torrent providers, plus 1080 quality support (thanks thezoggy), plus subtitles support with subliminal package from Diaoul.

This branch is on a very early stage and I need beta testers.

https://github.com/junalmeida/Sick-Beard/tree/torrent_1080_subtitles

You can download the ZIP/tarball. If replacing over existing setup, please be patient to update the database.
Always do a backup first.

Thanks
junalmeida
 
Posts: 4
Joined: Sat May 05, 2012 8:45 pm

Re: TorrentProviders + 1080 + subtitles

Postby nikagl » Wed Feb 20, 2013 4:42 pm

Nice, thanks. Testing now... haven't found a way to download subs yet (it didn't work out of the box), so will checkout whether I can find more info on how to configure (enable) this. I only added "nl,nl-nl,en-us" to subtitle languages in the postprocessing section of the Config tab...
nikagl
 
Posts: 5
Joined: Sun Aug 05, 2012 1:31 pm

Re: TorrentProviders + 1080 + subtitles

Postby nikagl » Wed Feb 20, 2013 5:03 pm

Silly me, just needed to also enable the Subtitles meta data as well :) works like a charm, thanks!!
nikagl
 
Posts: 5
Joined: Sun Aug 05, 2012 1:31 pm

Re: TorrentProviders + 1080 + subtitles

Postby junalmeida » Thu Mar 07, 2013 7:48 am

Nice!
junalmeida
 
Posts: 4
Joined: Sat May 05, 2012 8:45 pm

Re: TorrentProviders + 1080 + subtitles

Postby wookietv » Fri Mar 08, 2013 11:56 am

lately i've been getting this error and it doesn't start a download in utorrent.

Code: Select all
2013-03-08 12:34:26.870000 SEARCHQUEUE-RSS-SEARCH :: Error trying to load Kickass RSS feed: not well-formed (invalid token): line 185, column 77
2013-03-08 12:35:06.296000 SEARCHQUEUE-BACKLOG-194031 :: Error trying to load Kickass RSS feed: not well-formed (invalid token): line 20, column 77
2013-03-08 12:35:07.059000 SEARCHQUEUE-BACKLOG-194031 :: Error trying to load Kickass RSS feed: not well-formed (invalid token): line 16, column 77
2013-03-08 12:35:08.149000 SEARCHQUEUE-BACKLOG-194031 :: Error trying to load Kickass RSS feed: not well-formed (invalid token): line 39, column 77
2013-03-08 12:35:09.760000 SEARCHQUEUE-BACKLOG-194031 :: Error trying to load Kickass RSS feed: not well-formed (invalid token): line 16, column 77
2013-03-08 12:35:10.764000 SEARCHQUEUE-BACKLOG-194031 :: Error trying to load Kickass RSS feed: not well-formed (invalid token): line 35, column 77
2013-03-08 12:36:33.410000 SEARCHQUEUE-BACKLOG-194031 :: Error trying to load Kickass RSS feed: not well-formed (invalid token): line 20, column 77
2013-03-08 12:36:33.912000 SEARCHQUEUE-BACKLOG-194031 :: Error trying to load Kickass RSS feed: not well-formed (invalid token): line 16, column 77
2013-03-08 12:36:34.524000 SEARCHQUEUE-BACKLOG-194031 :: Error trying to load Kickass RSS feed: not well-formed (invalid token): line 39, column 77
2013-03-08 12:36:35.097000 SEARCHQUEUE-BACKLOG-194031 :: Error trying to load Kickass RSS feed: not well-formed (invalid token): line 16, column 77
2013-03-08 12:36:37.299000 SEARCHQUEUE-BACKLOG-194031 :: Error trying to load Kickass RSS feed: not well-formed (invalid token): line 35, column 77
2013-03-08 12:49:17.148000 SEARCHQUEUE-BACKLOG-194031 :: Error trying to load Kickass RSS feed: not well-formed (invalid token): line 20, column 77
2013-03-08 12:49:19.184000 SEARCHQUEUE-BACKLOG-194031 :: Error trying to load Kickass RSS feed: not well-formed (invalid token): line 16, column 77
2013-03-08 12:49:19.784000 SEARCHQUEUE-BACKLOG-194031 :: Error trying to load Kickass RSS feed: not well-formed (invalid token): line 39, column 77
2013-03-08 12:49:20.202000 SEARCHQUEUE-BACKLOG-194031 :: Error trying to load Kickass RSS feed: not well-formed (invalid token): line 16, column 77
2013-03-08 12:49:20.764000 SEARCHQUEUE-BACKLOG-194031 :: Error trying to load Kickass RSS feed: not well-formed (invalid token): line 35, column 77


as of 3/8/13, i'm updated to the latest version.
SB Version: alpha (torrentProviders) -- source : 55a42391664b1c460509a41a363e2b597b41d1c6
Python Version: 2.7.3 (default, Apr 10 2012, 23:31:26) [MSC v.1500 32 bit (Intel)]

if you need any other info, please let me know. thanks
wookietv
 
Posts: 1
Joined: Fri Mar 08, 2013 11:51 am

Re: TorrentProviders + 1080 + subtitles

Postby nesbcn » Wed Jun 04, 2014 6:08 am

Hi there,

I've been using this sickbeard fork with a lot of satisfaction, the same folder install has survived many different distros. But today was different, I was installing Linux Mint 17 (based on ubuntu 14.04 LTS), and I couldn't get Sickbeard to work; to be clear, the fork with torrent providers, 1080p and subtitles, since this is the one I want to use. I then followed the instructions in the wiki to make a new install but the problem was the same. The first error message looked like this:

Code: Select all
python /home/coconut/SickBeard/SickBeard.py &
[1] 23080
coconut@coconut ~ $ Traceback (most recent call last):
  File "/home/coconut/SickBeard/SickBeard.py", line 46, in <module>
    import sickbeard
  File "/home/coconut/SickBeard/sickbeard/__init__.py", line 35, in <module>
    from sickbeard import providers, metadata
  File "/home/coconut/SickBeard/sickbeard/metadata/__init__.py", line 23, in <module>
    import mediabrowser
  [...]
ImportError: No module named babelfish


This seemed related to python, and after some investigation plus some deduction of my own, came to the conclusion that it was missing some python modules. I don't know why the modules were not installed, maybe the defaults have changed with the new distro?
I then proceeded to install the missing module babelfish (search for package named python-babelfish), and started SB again. This time, it was complaining about a new module:

Code: Select all
Traceback (most recent call last):
  File "/home/coconut/SickBeard/SickBeard.py", line 46, in <module>
    import sickbeard
  File "/home/coconut/SickBeard/sickbeard/__init__.py", line 35, in <module>
    from sickbeard import providers, metadata
  File "/home/coconut/SickBeard/sickbeard/metadata/__init__.py", line 23, in <module>
    import mediabrowser
  File "/home/coconut/SickBeard/sickbeard/metadata/mediabrowser.py", line 25, in <module>
    import generic
 [...]
    import requests
ImportError: No module named requests


So I kept on installing the missing modules: requests, enzyme, guessit (this one was tricky as it is included in the package python-hachoir-metadata), until finally SB complained no more and launched as usual. So far it is working, and the version check shows that there is no update.
I don't know if this issue is related to my system, to this specific fork or if it affects the base...
Maybe this is something that should be investigated, I for one was pretty upset..

Hopefully this will serve if others encounter the same error(s).

Thanks for the great effort, this fork is the best!
nesbcn
 
Posts: 2
Joined: Mon Feb 18, 2013 3:52 am

Re: TorrentProviders + 1080 + subtitles

Postby nesbcn » Wed Jun 04, 2014 6:16 am

Hi there,

I've been using this sickbeard fork with a lot of satisfaction, the same folder install has survived many different distros. But today was different, I was installing Linux Mint 17 (based on ubuntu 14.04 LTS), and I couldn't get Sickbeard to work; to be clear, the fork with torrent providers, 1080p and subtitles, since this is the one I want to use. I then followed the instructions in the wiki to make a new install but the problem was the same. The first error message looked like this:

Code: Select all
python /home/coconut/SickBeard/SickBeard.py &
[1] 23080
coconut@coconut ~ $ Traceback (most recent call last):
  File "/home/coconut/SickBeard/SickBeard.py", line 46, in <module>
    import sickbeard
  File "/home/coconut/SickBeard/sickbeard/__init__.py", line 35, in <module>
    from sickbeard import providers, metadata
  File "/home/coconut/SickBeard/sickbeard/metadata/__init__.py", line 23, in <module>
    import mediabrowser
  [...]
ImportError: No module named babelfish


This seemed related to python, and after some investigation plus some deduction of my own, came to the conclusion that it was missing some python modules. I don't know why the modules were not installed, maybe the defaults have changed with the new distro?
I then proceeded to install the missing module babelfish (search for package named python-babelfish), and started SB again. This time, it was complaining about a new module:

Code: Select all
Traceback (most recent call last):
  File "/home/coconut/SickBeard/SickBeard.py", line 46, in <module>
    import sickbeard
  File "/home/coconut/SickBeard/sickbeard/__init__.py", line 35, in <module>
    from sickbeard import providers, metadata
  File "/home/coconut/SickBeard/sickbeard/metadata/__init__.py", line 23, in <module>
    import mediabrowser
  File "/home/coconut/SickBeard/sickbeard/metadata/mediabrowser.py", line 25, in <module>
    import generic
 [...]
    import requests
ImportError: No module named requests


So I kept on installing the missing modules: requests, enzyme, guessit (this one was tricky as it is included in the package python-hachoir-metadata), until finally SB complained no more and launched as usual. So far it is working, and the version check shows that there is no update.
I don't know if this issue is related to my system, to this specific fork or if it affects the base...
Maybe this is something that should be investigated, I for one was pretty upset..

Hopefully this will serve if others encounter the same error(s).

Thanks for the great effort, this fork is the best!
nesbcn
 
Posts: 2
Joined: Mon Feb 18, 2013 3:52 am

Re: TorrentProviders + 1080 + subtitles

Postby paultje3181 » Sat Apr 16, 2016 2:20 am

I just installed your fork on my raspberry pi. Configureren and the logs show found episodes. But none of them het downloaded.

Logs:
Code: Select all
2016-04-16 08:46:11 WARNING  SHOWQUEUE-ADD :: URL error [Errno -2] Naam of dienst is niet bekend while loading URL http://services.tvrage.com/tools/quickinfo.php?ep=1x1&show=The+Originals
2016-04-16 08:46:11 WARNING  SHOWQUEUE-ADD :: Error encountered while checking TVRage<->TVDB sync: urlopen call to http://services.tvrage.com/tools/quickinfo.php?ep=1x1&show=The+Originals failed

Looks like tvrage.com is Down. But is there a way to fix this? Or to use tvdb?
paultje3181
 
Posts: 1
Joined: Sat Apr 16, 2016 2:09 am

Re: TorrentProviders + 1080 + subtitles

Postby jurrabi » Thu Dec 08, 2016 11:11 am

Hi there,

I've been using this branch for some time and I find it very usefull. Thanks a lot.

For a while now, I'm getting an error when grabbing magnet links. I get an error on the log like:
Code: Select all
2016-12-08 18:08:26 SEARCHQUEUE-MANUAL-SEARCH :: [Deluge] _sendTORRENT() Error grabbing torrent from magnet:?xt=urn.....


The magnet works fine when pasted directly in deluge.

Any ideas?
jurrabi
 
Posts: 7
Joined: Wed May 26, 2010 1:41 pm

Re: TorrentProviders + 1080 + subtitles

Postby jurrabi » Sat Jan 28, 2017 6:08 am

Update everything to latest versions and same issue remains. Nobody having this same issue?
jurrabi
 
Posts: 7
Joined: Wed May 26, 2010 1:41 pm


Return to Torrent Edition (junalmeida)

Who is online

Users browsing this forum: No registered users and 1 guest